Jump to content


Wargaming Game Center Not Running


  • Please log in to reply
3 replies to this topic

Top_Bogg #1 Posted 28 April 2017 - 06:50 PM

    Private

  • Closed Alpha Gladiators
  • 1
  • Member since:
    05-18-2012

I'll try to explain this as best I can and hopefully someone might have an answer. I just received an invitation code to participate in the Alpha Test yesterday, so I followed the instructions and entered my code on WG's website. That prompted another email to be sent which had information about downloading and installing the Game Center and Total War itself. This is where I've run into a problem. When I launch the installer application I downloaded for Game Center, nothing happens. It simply won't install. I've restarted my PC and ran the installer as an admin but nothing is working. Has anyone else had this problem? If so, did you find a way to fix it? I've waited so long for an invite to test this game and I finally get it only to be rejected by a bugged installer application. Hate to say it but "typical WG"...always something broken. Would love some assistance if someone can offer it. Thanks in advance! 

 

I've also read other threads and I was still unable to find a concrete answer to a problem like this.

 

SOLVED: So after spending way more time than I should have, I think I found a solution. On top of running the program as an administrator, I had to run in it compatibility mode with Windows XP (Service Pack 3). That seems to have fixed it and I was unable to start the install process. What or why this problem exists is beyond me but hopefully this helps others who encounter the same problem.


Edited by Top_Bogg, 28 April 2017 - 07:52 PM.


Ardez #2 Posted 28 April 2017 - 06:51 PM

    Zhayedan

  • Players
  • 1,301
  • Member since:
    03-06-2012
Ignore me.

Edited by Ardez, 28 April 2017 - 06:51 PM.


Cicero30 #3 Posted 28 April 2017 - 09:28 PM

    Private

  • Closed Alpha Gladiators
  • 1
  • Member since:
    06-12-2011

View PostTop_Bogg, on 28 April 2017 - 06:50 PM, said:

I'll try to explain this as best I can and hopefully someone might have an answer. I just received an invitation code to participate in the Alpha Test yesterday, so I followed the instructions and entered my code on WG's website. That prompted another email to be sent which had information about downloading and installing the Game Center and Total War itself. This is where I've run into a problem. When I launch the installer application I downloaded for Game Center, nothing happens. It simply won't install. I've restarted my PC and ran the installer as an admin but nothing is working. Has anyone else had this problem? If so, did you find a way to fix it? I've waited so long for an invite to test this game and I finally get it only to be rejected by a bugged installer application. Hate to say it but "typical WG"...always something broken. Would love some assistance if someone can offer it. Thanks in advance! 

 

I've also read other threads and I was still unable to find a concrete answer to a problem like this.

 

SOLVED: So after spending way more time than I should have, I think I found a solution. On top of running the program as an administrator, I had to run in it compatibility mode with Windows XP (Service Pack 3). That seems to have fixed it and I was unable to start the install process. What or why this problem exists is beyond me but hopefully this helps others who encounter the same problem.

 

​I actually had this same problem so I hope a dev team has read this..cause I fixed the issue the same way he did. ty

Jambijon #4 Posted 04 May 2017 - 10:43 PM

    CS Specialist

  • Administrator
  • 30
  • Member since:
    07-02-2014

There's some helpful info in this article: https://na.wargaming...kb/articles/704

 

If you run into any other issues, send a ticket to our customer support team






1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users