Jump to content

Fatal Error - Untrusted system file (C:\Windows\System32\scpicli.dll)

Fatal Error Untrusted system file scpicli.dll EAC sucks Communism Heresy Cavalry are op So are archers The Grand Tour is awesome So are chicken strips

  • Please log in to reply
3 replies to this topic

ExRedux #1 Posted 05 December 2017 - 05:19 AM


  • Closed Alpha Gladiators
  • 1
  • Member since:

Game ran fine for 2 days with no issues. Then I received this error message when trying to launch the game.

Things I've done:

Ran the game and launcher as administrator.

Ran the repair installation option in the Wargaming launcher.

Uninstalled TW:Arena and Easy Anti-cheat, and deleted remaining files (appdata), then reinstalled both.

Disabled my AV (NOD32), and checked my AV logs to see if it was blocking anything (it wasn't).

Checked scpicli.dll's digital signatures and verified (it verified, and is distributed by microsoft).

Disabled scpicli.dll anyway (computer BSOD'd, and rebooted).

Ran "sfc /scannow" in CMD as administrator. (No issues).

Ran the repair installation option in the Wargaming launcher again.

Uninstalled TW:Arena and EAC again, and deleted remaining files, then reinstalled again.

Furiously tried launching the game about 30 times back to back while watching The Grand Tour.

Sent a support ticket to wargaming and received no answer for over 24 hours.

Tried launching the game a few more times while eating chicken strips.

Uninstalled and currently reinstalling.

Posted about the error on this forum and on the EAC forum.


Things I am going to do:

Continue spam launching the game out of spite for the next half hour while playing Dominions 5.


The game's logs don't mention any errors, I'd post one but I deleted them while deleting existing game files.


There was no patches or updates of any kind (game or otherwise).

Ardez #2 Posted 05 December 2017 - 05:59 AM


  • Praetorian
  • 2,237
  • Member since:
It definitely looks like an EAC issue based on my research. I'd suggest reaching out to the EAC team to help investigate.

Cottonerer #3 Posted 06 February 2018 - 10:23 AM


  • Players
  • 1
  • Member since:

Hi! It’s been a while. But this can help you. Maybe you installed another program that conflicts with the game. Try performing System Restore and see if it works. What is System Restore you can find here. If you don't have latest version of this dll file or maybe it's corrupted you can download it manually from this site 

jack_adision #4 Posted 19 February 2018 - 10:15 AM


  • Players
  • 1
  • Member since:

If you want to deal with game crashing with Untrusted system file (C:\Windows\System32\scpicli.dll) error, you should follow the below given tricks:

  • Delete local content and re-install
  • Run regsvr32 /i file_name.dll, regsvr32 /u file_name.dll,  during error runtime
  • First verify Integrity of game cache
  • Re-install $/steamapps/common/squad/squad_launcher.exe -> properties -> digital signature -> view certificate -> install certificate
  • Download replace DXGIDebug.dll and placed in $/Windows/Syswow64/
  • Update DirectX End User Runtime

1 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users